postgres Module

Greg Fausak

Edited by

Greg Fausak

Revision History
Revision $Revision: 5898 $$Date$

Table of Contents

1. Admin Guide
1.1. Overview
1.2. Dependencies
1.2.1. OpenSIPS Modules
1.2.2. External Libraries or Applications
1.3. Exported Parameters
1.3.1. exec_query_threshold (integer)
1.4. Exported Functions
1.5. Installation and Running

List of Examples

1.1. Set exec_query_threshold parameter

Chapter 1. Admin Guide

1.1. Overview

Module description

1.2. Dependencies

1.2.1. OpenSIPS Modules

The following modules must be loaded before this module:

  • No dependencies on other OpenSIPS modules.

1.2.2. External Libraries or Applications

The following libraries or applications must be installed before running OpenSIPS with this module loaded:

  • PostgreSQL library - e.g., libpq5.

  • PostgreSQL devel library - to compile the module (e.g., libpq-dev).

1.3. Exported Parameters

1.3.1. exec_query_threshold (integer)

If queries take longer than 'exec_query_threshold' microseconds, warning messages will be written to logging facility.

Default value is 0 - disabled.

Example 1.1. Set exec_query_threshold parameter

modparam("db_postgres", "exec_query_threshold", 60000)

1.4. Exported Functions


1.5. Installation and Running

Notes about installation and running.